1. Если Вы видите это сообщение, значит, вы ещё не зарегистрировались на нашем форуме.

    Зарегистрируйтесь, если вы хотите принять участие в обсуждениях. Перед регистрацией примите к сведению:
    1. Не регистрируйтесь с никами типа asdfdadhgd, 354621 и тому подобными, не несущими смысловой нагрузки (ник должен быть читаемым!): такие пользователи будут сразу заблокированы!
    2. Не регистрируйте больше одной учётной записи. Если у вас возникли проблемы при регистрации, то вы можете воспользоваться формой обратной связи внизу страницы.
    3. Регистрируйтесь с реально существующими E-mail адресами, иначе вы не сможете завершить регистрацию.
    4. Обязательно ознакомьтесь с правилами поведения на нашем форуме, чтобы избежать дальнейших конфликтов и непонимания.
    С уважением, администрация форума Old-Games.RU
    Скрыть объявление
  2. Пожалуйста, внимательно прочитайте правила раздела.

Оптимальные версии драйверов Nvidia и ATI для AGP-видеокарт

Тема в разделе "Hard & Soft", создана пользователем Thomas Wolfe, 12 янв 2018.

  1. Thomas Wolfe

    Thomas Wolfe

    Регистрация:
    27 авг 2015
    Сообщения:
    3.133
    Камрад @BrainRipper занимается полезным делом, отслеживая баги в драйверах видеокарт, в связи с чем возникло желание создать эту тему, в которой были бы собраны рекомендации по наиболее подходящим версиям драйверов для видеокарт Nvidia и ATi (в первую очередь, для AGP-порта), возможно, конкретизированные относительно отдельных чипсетов, игр и операционных систем. Желательно, для наилучшего восприятия, представлять материал тезисно. Благодарю всех, кто примет участие :)
     
    Vardok и TakedaSun нравится это.
  2.  
  3. TheMadLynx

    TheMadLynx

    Хелпер

    Регистрация:
    9 июн 2015
    Сообщения:
    3.566
    Тогда уж 3dfx можно добавить до кучи. В их отношении тоже не действует правило, что самый последний драйвер == самый лучший.
     
  4. Thomas Wolfe

    Thomas Wolfe

    Регистрация:
    27 авг 2015
    Сообщения:
    3.133
    @TheMadLynx, я только за, если есть прецеденты. Сам сталкивался только с фактом неработоспособности/нестабильности вообще всех версий драйверов на некоторых чипсетах.
     
  5. BrainRipper

    BrainRipper

    Регистрация:
    1 ноя 2009
    Сообщения:
    8.403
    На GeForce4 MX 440 и GeForce4 Ti 4200 под WinXP нельзя ставить что-нибудь выше чем 78.05.
    На GeForce FX - ничего выше 163.75.
    И ещё заметил такую закономерность: в некоторых сериях драйверов NVidia нужно ставить самый последний в пределах этой серии. Что логично: найденные баги исправляются, а новых возможностей и оптимизаций, которые могли бы вызвать новые баги, в них не добавляют.
    Например, серия ForceWare 65 содержит в себе версии с 66.77 по 67.66. Версии 66.81-67.03 - глючные, а 67.66 - нормальный. ForceWare 70 - это 71.84, 71.89 и 72.14. Нормальным из них является лишь 72.14 (замечу, что в нём нет поддержки GeForce3 /Ti 200/500, Geforce4 Ti 4*00).

    Версии 61.76-61.82, 67.66 и 72.14 - условно-рабочие. Глючат только две старые игры (конечно, я протестировал не так уж много игр): Blood версии 1.0 и 1.01 - лечится патчем 2.0 или выше, и Need for Speed: High Stakes - лечится копированием файла d3da.dll из папки 3dSetup в корневую папку игры (с заменой).

    Под Win98 на GeForce2 MX 400, GeForce4 MX 440 и GeForce FX не стоит ставить драйвера новее 56.64, потому что не получите ничего кроме проблем.

    P.S. Насчёт только двух игр я поторопился: есть небольшая проблемка в Carmageddon II и, кроме того на 72.14 (и выше) проблемы в Unreal Gold (режим Direct3D с 32-битным цветом).
     
    Последнее редактирование: 9 июн 2018
    WAR1OCK, Tristana, B13 и 7 другим нравится это.
  6. Teron Lifeslayer Malkavian

    Teron Lifeslayer

    Регистрация:
    14 ноя 2004
    Сообщения:
    7.560
    Под FX и Ко уже давно нашли оптимальный драйвер для старья - Detonator 45.xx. Даже для ранних DX9 игр они все равно немощные.
     
  7. BrainRipper

    BrainRipper

    Регистрация:
    1 ноя 2009
    Сообщения:
    8.403
    У него есть некоторые проблемы в работе с мониторами, и это не считая проблем с некоторыми играми. Почему-то он как бы находит другой (несуществующий) монитор и переключается на него.
    В ветке HKEY_CURRENT_CONFIG\System\CurrentControlSet\Control\VIDEO\{5BE33440-1389-4917-AE42-7D662F93A52A}\0000 болтаются два монитора, так быть не должно.
     
  8. TakedaSun

    TakedaSun

    Регистрация:
    27 дек 2009
    Сообщения:
    672
    Иногда бывают исключения из правил, долгое время пользовался видеокартой Geforce 3 Ti200, когда уже в продаже были карты серии GF6xxx.
    Драйвер использовал версии 4x.xx (точно не помню версию, давно уже было) так как показывал более высокие показатели производительности в отличие от более новых. Решил поиграть в need for speed underground, но в разрешении 1024x768 fps был не очень комфортный, обновил драйвер на 8x.xx и какого было мое удивление, скорость возросла процентов на 30. После этого с удовольствием прошел игру, а то уже хотел бежать в магазин за новой картой.
     
  9. BrainRipper

    BrainRipper

    Регистрация:
    1 ноя 2009
    Сообщения:
    8.403
    @TakedaSun, я ведь не про то писал. А про то, что 67.66 лучше чем 66.93, 72.14 лучше чем 71.89.
    Уверен, что результат на 67.66, например, был бы не хуже, а то и чуть лучше.
    Старые видеокарты
    Soft - Баги в драйверах NVidia
     
  10. kreol Старший офицер Чёрной Гвардии

    kreol

    Администратор

    Регистрация:
    2 июл 2007
    Сообщения:
    93.763
    В каких конкретно играх?
     
  11. BrainRipper

    BrainRipper

    Регистрация:
    1 ноя 2009
    Сообщения:
    8.403
    @kreol, Soft - Баги в драйверах NVidia
    Unreal Gold, режим Direct3D с 32-битным цветом.
    Descent 3, режим Direct3D
    Future Cop L.A.P.D.
    Carmageddon II: Carpocalypse Now


    Need for Speed III: Hot Pursuit, Need for Speed High Stakes, Need for Speed Porsche Unleashed запустить можно на 71.84 (и выше) только с заменой библиотек рендерера. А на 61.76 и 66.94 они не заработают нормально ни в каком виде.
     
    Последнее редактирование: 12 янв 2018
  12. Vardok

    Vardok

    Регистрация:
    25 июн 2009
    Сообщения:
    869
    Теме жирный плюс. У меня на данный момент три основных видеокарты, пока так и не определился какую использовать как основную в Вин98:
    64 мб GeForce 3 Ti200, 128 мб GeForce 4 Ti4200, 128 мб Radeon 9700.
    Радеон пока еще вообще не ставил, купил его в надежде, что он заработает на повышенной частоте шины АГП на 133 мгц шины в 440вх. Да и в Сталкера на ВинХР хотелось погонять немного)))) Поэтому даже и не знаю что для него можно в Вин98 подобрать.
    На ДжеФорсы ставил 45,23, вроде как раз @BrainRipper его и советовал.
    На спарке Вуды2 стоит пакет FastVoodoo 2.4.6
    На Вуде3 стоит (точнее стоял, комп этот разобран пока что) пакет Amigamerlin 2.9.
    Отсоветуйте или подтвердите пожалуйста выбор драйверов:worthy:
     
  13. BrainRipper

    BrainRipper

    Регистрация:
    1 ноя 2009
    Сообщения:
    8.403
    На Radeon 9200 и 9600 под Win98 лучше не ставить 6.2 (последний драйвер под эту ОС), он был выпущен для карт, в которых графический чип PCI-E был сопряжён с AGP-интерфейсом через мост Rialto. Вроде по совместимости он ничуть не лучше чем 5.9, а производительность ниже.
     
    Soundoomer, Revolter и Vardok нравится это.
  14. kreol Старший офицер Чёрной Гвардии

    kreol

    Администратор

    Регистрация:
    2 июл 2007
    Сообщения:
    93.763
    @BrainRipper, по возможности проверю, какие у меня там драйвера (версию на память не помню). Но с этими играми проблем не встречал.
    А вот с Armor Command встречал, причём вот что удивительно: при одной и той же версии драйверов на одной и той же машине (расписанной у меня в профиле) она в среде Windows 2000 работает, а вот в среде Windows 98SE - нет; при этом если во второй ОС поставить более старую версию драйверов - то работает нормально. Собственно, именно ради неё и понизил в своё время.
     
  15. BrainRipper

    BrainRipper

    Регистрация:
    1 ноя 2009
    Сообщения:
    8.403
    @Vardok, версия драйвера зависит от того, в какие конкретно игры вы хотите играть.
     
  16. Vardok

    Vardok

    Регистрация:
    25 июн 2009
    Сообщения:
    869
    @BrainRipper, в самые разнообразные, гулять - так гулять. От ДОС-игр (типа Krondor, M&M и прочих РПГ первой половины 90-х, игр на Build) до Морровинда, Мафии и ГТА
     
  17. BrainRipper

    BrainRipper

    Регистрация:
    1 ноя 2009
    Сообщения:
    8.403
    Vardok нравится это.
  18. TakedaSun

    TakedaSun

    Регистрация:
    27 дек 2009
    Сообщения:
    672
  19. BrainRipper

    BrainRipper

    Регистрация:
    1 ноя 2009
    Сообщения:
    8.403
    Thomas Wolfe нравится это.
  20. Gamecollector

    Gamecollector

    Регистрация:
    23 сен 2016
    Сообщения:
    1.878
    Нормально Catalyst 6.2 с картами без моста работает. Radeon X850 PE несколько лет так использовал.

    Классический метод для тестирования Radeon - Anachronox (лифт в доках, музей и Sendormintory), Test Drive 5. Увы, карта вроде как помЭрла (хотя есть шанс, что это у неё так несовместимость с Voodoo2 выглядит).
     
    Последнее редактирование: 13 янв 2018
  21. BrainRipper

    BrainRipper

    Регистрация:
    1 ноя 2009
    Сообщения:
    8.403
    Никто не говорил, что он не работает. Работает, но медленнее.
     
    Последнее редактирование: 13 янв 2018
  1. На этом сайте используются файлы cookie, чтобы персонализировать содержимое, хранить Ваши предпочтения и держать Вас авторизованным в системе, если Вы зарегистрировались.
    Продолжая пользоваться данным сайтом, Вы соглашаетесь на использование нами Ваших файлов cookie.
    Скрыть объявление